読者です 読者をやめる 読者になる 読者になる

プログラミングの魔物

エラー、バグ、仕様変更と戦うブログ

Lua5.1とLua5.2の互換性

現在はLua5.1を使用中。

まだ5.2へ移行する予定はないが、いつでも移行できるように注意すべきポイントを把握しておこうと思う。
具体的にはココを読んでおけばオッケー(手抜き)
http://milkpot.sakura.ne.jp/lua/lua52_manual_ja.html#8.1


とりあえずLua5.2でも動くように過去の記事を修正しておいた。
Lua5.2ではモジュールに関わる変更点があるので、5.1で定義したモジュールを使う場合には注意が必要だ。